Inicio > PHP, Web > Moodle sumamente lento en WAMP

Moodle sumamente lento en WAMP


Wamp

En el trabajo he tenido que instalar un Moodle sobre un servidor WAMP, y además de varios problemas al instalarlo, me he encontrado con unos tiempos de carga incomprensibles (hasta 150 segundos…) con un solo usuario.

Tras una búsqueda, me he encontrado con esta solución en StackOverflow que os traduzco aquí.

Tendréis que buscar las distintas opciones, descomentarlas si están comentadas y colocar el valor que os muestro;

Lo primero será modificar el http.conf :

EnableMMAP on
EnableSendfile on

El siguiente paso será editar el php.ini para aumentar la caché del realpath

realpath_cache_size= 4m

Finalmente cambiaremos el my.ini para mejorar el rendimiento de MySQL.

innodb_flush_log_at_trx_commit = 2

Si os soy sincero, desconozco que hace cada una de las opciones, pero el aumento de rendimiento ha sido considerable.

Anuncios
Categorías:PHP, Web Etiquetas: , , ,
  1. Aún no hay comentarios.
  1. No trackbacks yet.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: