Inicio > Linux > Problemas con subtítulos UTF-8 en GNU/Linux

Problemas con subtítulos UTF-8 en GNU/Linux


Subtítulos

 

En determinadas ocasiones, cuando añadimos subtítulos a vídeos en GNU/Linux, algunos caracteres especiales no se ven correctamente, como las tildes.

La solución más habituales es, con un editor como Gedit o Kate, guardarlo como UTF-8, pero esto no funciona con los archivos que tienen activado el BOM.

Para saber si está activo, basta con ejecutar en un terminal file ficherosubtitulo.srt, si te devuelve UTF-8 Unicode (with BOM) text es que tiene está activo el modo BOM.

Este modo se especifica en los primeros 4 bytes del fichero y es copiado en muchas ocasiones al copiar y pegar todo el texto del fichero, la forma más segura de eliminarlo es usando  tail –bytes=+4 ficherosubtitulo.srt > ficherosubtitulosinbom.srt

He encontrado este problema en distintas distribuciones, como Ubuntu y ArchLinux, y en reproductores como el VLC y el MPlayer.

Desgraciadamente no he encontrado ninguna forma para que añadir soporte para este tipo de subtítulo a los reproductores, pues si el subtítulo está en el propio fichero tendrás que extraerlo y modificarlo.

Anuncios
Categorías:Linux Etiquetas: , , , , , , ,
  1. Aún no hay comentarios.
  1. No trackbacks yet.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: